В соответствии с этой ошибкой, версия PHP 5.3.10, которая входит в Fedora 16 не включает libzip.

Но мне для Joomla требуется PHP-модуль libzip, его отсутствие очень сильно ограничивает возможности Joomla.

Следуйте шагам ниже, для установки php-модуля libzip:

# cd /tmp
# wget http://pecl.php.net/get/zip-1.10.2.tgz
# tar zxf zip-1.10.2.tgz
# cd zip-1.10.2
# phpize
# ./configure
# make
# make install
# rm -fr /tmp/zip-1.10.2.tgz ; rm -fr /tmp/zip-1.10.2


После этого не забудьте создать файл /etc/php.d/zip.ini со строкой внутри

extension=zip.so

Добавить комментарий


Защитный код
Обновить