1 1 1 1 1 Rating 0.00 (0 Votes)
Вы можете использовать PPA для использования современных версий PHP, или установки прошлой версии PHP. (Например PHP 5.6 на Ubuntu 16.04 LTS)

Наиболее часто используется репозиторий от Ondřej Surý, Debian PHP разработчика:

ppa:ondrej/php (для PHP 5.6/7.0/7.1 и их подверсий, PHP 5.5 больше не поддерживается официально)

Пакет совместимости php5:
ppa:ondrej/php5-compat (для подмены php5 что бы разрешить зависимости со старыми пакетами (не точный перевод))

PHP PPA раньше содержал в себе Apache 2.4 обновления. Больше этих обновлений нет, они находятся в отдельном репозитории Apache 2.4:
ppa:ondrej/apache2 (для Apache 2.4)

Если вы всё же хотите использовать этот PPA, сделайте следующее:
ppa:ondrej/php (для PHP 5.6/7.0/7.1)
sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php7.1 # для PHP 7.1
sudo apt-get install php7.0 # для PHP 7.0
sudo apt-get install php5.6 # для PHP 5.6​

ppa:ondrej/php5-compat (для php5 compat)

sudo add-apt-repository ppa:ondrej/php
sudo add-apt-repository ppa:ondrej/php5-compat
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php5 # это установит php5.6 пакет ​

Если у вас нет add-apt-repository, выполните следующее:
sudo apt-get install python-software-properties​

Самая последняя версия PHP 5.4 сейчас находится в отдельном репозитории PPA: ppa:ondrej/php5-oldstable

Пожалуйста обратите внимание что у PHP 5.4 закончился срок поддержки ещё 3 сентября 2015 и оно не получает сейчас никаких обновлений безопасности. Рекомендуем обновляться сразу хотя бы на PHP 5.6, оно хоть будет получать обновления до 31 декабря 2018.

Перевод